切换风格

默认Lavender Sky Flowers Wizard Snow Beige California City Dragon Black London Sunset glow Pink Cloud

14

主题

400

积分

0

精华

用户组 

易积分
308
热心
0
好评
1
易语言转 E4A 如何写法[复制链接]
发表于 2024-4-28 01:31:19 | 显示全部楼层 |阅读模式
50易积分

时间分割 = 分割文本 (到期时间, “/”, )
.如果真 (取数组成员数 (时间分割) < 5)
    返回 (“错误的到期时间!”)
.如果真结束
.计次循环首 (长度 - 16, X)
    结果 = 结果 + 字符 (取随机数 (65, 90))
.计次循环尾 ()
.如果真 (取文本长度 (时间分割 [2]) < 2)
    时间分割 [2] = “0” + 时间分割 [2]
.如果真结束
.如果真 (取文本长度 (时间分割 [3]) < 2)
    时间分割 [3] = “0” + 时间分割 [3]
.如果真结束
.如果真 (取文本长度 (时间分割 [4]) < 2)
    时间分割 [4] = “0” + 时间分割 [4]
.如果真结束
.如果真 (取文本长度 (时间分割 [5]) < 2)
    时间分割 [5] = “0” + 时间分割 [5]
.如果真结束
时间1 = 到字节集 (时间分割 [1])
时间2 = 到字节集 (时间分割 [2])
时间3 = 到字节集 (时间分割 [3])
时间4 = 到字节集 (时间分割 [4])
时间5 = 到字节集 (时间分割 [5])
.计次循环首 (取字节集长度 (时间1), X)
    时间1 [X] = 时间1 [X] + 17
.计次循环尾 ()
.计次循环首 (取字节集长度 (时间2), X)
    时间2 [X] = 时间2 [X] + 17
.计次循环尾 ()
.计次循环首 (取字节集长度 (时间3), X)
    时间3 [X] = 时间3 [X] + 17
.计次循环尾 ()
.计次循环首 (取字节集长度 (时间4), X)
    时间4 [X] = 时间4 [X] + 17
.计次循环尾 ()
.计次循环首 (取字节集长度 (时间5), X)
    时间5 [X] = 时间5 [X] + 17
.计次循环尾 ()


最佳答案

查看完整内容

变量 到期时间 为 文本型 变量 结果 为 整数型 变量 时间分割 为 文本型 '具体变量什么类型自己选择有:逻辑型,字节型,短整数型,整数型,通用型,具体在-左侧类库——e4a核心类库——数据类型查看 时间分割 = 分割文本 (到期时间, “/”, ) 如果 (取数组成员数 (时间分割) < 5) 则 调试输出 (“错误的到期时间!”) 结束 如果 变量循环首 长度 至 长度 - 16 步进 1 '变量循环,变量"计数"从1递增到100,每次递增 ...
易如意中文编程学习交流论坛有你更精彩~
回复

使用道具 举报

16

主题

208

积分

0

精华

用户组 

易积分
399
热心
0
好评
0
发表于 2024-4-28 01:31:20 | 显示全部楼层
QQ浏览器截图20240429211631.png
        变量 到期时间 为 文本型
        变量 结果 为 整数型
        变量 时间分割 为 文本型 '具体变量什么类型自己选择有:逻辑型,字节型,短整数型,整数型,通用型,具体在-左侧类库——e4a核心类库——数据类型查看
        时间分割 = 分割文本 (到期时间, “/”, )
   如果 (取数组成员数 (时间分割) < 5) 则
    调试输出 (“错误的到期时间!”)
        结束 如果
               
       
        变量循环首 长度 至 长度 - 16 步进 1 '变量循环,变量"计数"从1递增到100,每次递增值为步进值1,步进值默认为1,这里就可以省略不写,步进值也可以为负数,表示递减
                结果 = 结果 + 字符 (取随机数 (65, 90))
        变量循环尾

易如意中文编程学习交流论坛有你更精彩~
回复

使用道具 举报

5

主题

175

积分

0

精华

用户组 

易积分
516
热心
0
好评
0
发表于 2024-4-30 08:08:18 | 显示全部楼层
好多呀。
居然没有写记录,如意还有这么一个功能。
回复

使用道具 举报

0

主题

22

积分

0

精华
易积分
33
热心
0
好评
0
发表于 2024-5-2 14:58:44 | 显示全部楼层
易如意中文编程学习交流论坛有你更精彩~
易如意中文编程学习交流论坛有你更精彩~
回复

使用道具 举报

QQ|sitemap|免责声明|RGB颜色对照表|手机版|小黑屋| 易如意 - E4A中文编程学习交流论坛

GMT+8, 2024-7-17 03:52 , Processed in 0.037968 second(s), 35 queries .

Powered by Discuz! X3.4

© 2001-2018 eruyi.cn

返回顶部